Directory Traversal in serve
CVE-2018-3712GHSA-q2qh-cgc2-qhr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (serve 6.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm serve
- Affected
- <= 6.4.8
- Fixed in
- 6.4.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q2qh-cgc2-qhr3 lists affected ranges: npm serve >=0 <6.4.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2qh-cgc2-qhr3 lists affected ranges: npm serve >=0 <=6.4.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-3712: 1.79% estimated exploitation activity in the next 30 days; percentile 78.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of serve do not properly handle %2e (.) and %2f (/) characters, and allow the, characters to be used in paths. This can be used to traverse the directory tree and list content of any directory the user running the process has access to. Mitigating factors: This vulnerability only allows listing of directory contents and does not allow reading of arbitrary files. Recommendation Update to version 6.4.9 later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q2qh-cgc2-qhr3
- Revision 1 · created ·
Published from osv record GHSA-q2qh-cgc2-qhr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-3712 Advisory: Directory Traversal in serve IDs: CVE-2018-3712, GHSA-q2qh-cgc2-qhr3 Record: https://patchnext.com/advisories/cve-2018-3712 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: serve 6.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm serve: affected <= 6.4.8; fixed in 6.4.9 ## Suggested inspection (read-only) - `npm ls serve --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on serve. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q2qh-cgc2-qhr3 (OSV record GHSA-q2qh-cgc2-qhr3 lists affected ranges: npm serve >=0 <6.4.9 (fixed)) - Verified: https://github.com/advisories/GHSA-q2qh-cgc2-qhr3 (GitHub-reviewed advisory GHSA-q2qh-cgc2-qhr3 lists affected ranges: npm serve >=0 <=6.4.8) Commands are suggestions: review each one before running it.
Loading voting…