Skip to content

← Public intelligence

npm package

sails-hook-sockets

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Improper Input Validation in sails-hook-sockets

    CVE-2018-21036 · GHSA-f7f4-hqp2-7prc

    Affected
    • npm sails-hook-sockets < 1.5.5
    Fixed in
    1.5.5· Vendor fix available
    Issue
    Sails.js before v1.0.0-46 allows attackers to cause a denial of service with a single request because there is no error handler in sails-hook-sockets to handle an empty pathname in a WebSocket request.

    Recommended action: Upgrade to 1.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →