Skip to content

← Actionable
High, CVSS 7.5amended

Improper Input Validation in sails-hook-sockets

CVE-2018-21036GHSA-f7f4-hqp2-7prc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sails-hook-sockets 1.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-21036: 1.77% estimated exploitation activity in the next 30 days; percentile 78.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Sails.js before v1.0.0-46 allows attackers to cause a denial of service with a single request because there is no error handler in sails-hook-sockets to handle an empty pathname in a WebSocket request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f7f4-hqp2-7prc

  2. Revision 1 · created ·

    Published from osv record GHSA-f7f4-hqp2-7prc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-21036

Advisory: Improper Input Validation in sails-hook-sockets
IDs: CVE-2018-21036, GHSA-f7f4-hqp2-7prc
Record: https://patchnext.com/advisories/cve-2018-21036 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sails-hook-sockets 1.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sails-hook-sockets: affected < 1.5.5; fixed in 1.5.5

## Suggested inspection (read-only)
- `npm ls sails-hook-sockets --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sails-hook-sockets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f7f4-hqp2-7prc (OSV record GHSA-f7f4-hqp2-7prc lists affected ranges: npm sails-hook-sockets >=0 <1.5.5 (fixed))
- Verified: https://github.com/advisories/GHSA-f7f4-hqp2-7prc (GitHub-reviewed advisory GHSA-f7f4-hqp2-7prc lists affected ranges: npm sails-hook-sockets >=0 <1.5.5)

Commands are suggestions: review each one before running it.

Loading voting…