High, CVSS 8.9npmAmendedPublished
jrburke requirejs vulnerable to prototype pollution
CVE-2024-38999 · GHSA-x3m3-4wpv-5vgc
- Affected
- npm requirejs <= 2.3.6
- Fixed in
- 2.3.7· Vendor fix available
- Issue
- jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts..configure. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Recommended action: Upgrade to 2.3.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.