Skip to content

← Actionable
High, CVSS 8.9amended

jrburke requirejs vulnerable to prototype pollution

CVE-2024-38999GHSA-x3m3-4wpv-5vgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (requirejs 2.3.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-38999: 0.84% estimated exploitation activity in the next 30 days; percentile 58.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts..configure. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x3m3-4wpv-5vgc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x3m3-4wpv-5vgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-38999

Advisory: jrburke requirejs vulnerable to prototype pollution
IDs: CVE-2024-38999, GHSA-x3m3-4wpv-5vgc
Record: https://patchnext.com/advisories/cve-2024-38999 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: requirejs 2.3.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm requirejs: affected <= 2.3.6; fixed in 2.3.7

## Suggested inspection (read-only)
- `npm ls requirejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on requirejs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3m3-4wpv-5vgc (OSV record GHSA-x3m3-4wpv-5vgc lists affected ranges: npm requirejs >=0 <2.3.7 (fixed))
- Verified: https://github.com/advisories/GHSA-x3m3-4wpv-5vgc (GitHub-reviewed advisory GHSA-x3m3-4wpv-5vgc lists affected ranges: npm requirejs >=0 <=2.3.6)

Commands are suggestions: review each one before running it.

Loading voting…