UnratednpmAmendedPublished
Arbitrary Code Execution in require-node
GHSA-8j6j-4h2c-c65p
- Affected
- npm require-node < 1.3.4; >= 2.0.0, < 2.0.4
- Fixed in
- 2.0.41.3.4· Vendor fix available
- Issue
- Versions of require-node prior to 1.3.4 for 1.x and 2.0.4 for 2.x are vulnerable to Arbitrary Code Execution. The package fails to sanitize requests to the require-node endpoint, allowing attackers to execute arbitrary code in the server through the injection of OS commands in the request body. Recommendation - If you are using 1.x, upgrade to version 1.3.4 or later. - If you are using 2.x, upgrade to version 2.0.4 or later.
Recommended action: Upgrade to 2.0.4 or 1.3.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.