Skip to content

← Actionable
Unratedamended

Arbitrary Code Execution in require-node

GHSA-8j6j-4h2c-c65p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (require-node 2.0.4, 1.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm require-node

    Affected
    < 1.3.4>= 2.0.0, < 2.0.4
    Fixed in
    2.0.4, 1.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions of require-node prior to 1.3.4 for 1.x and 2.0.4 for 2.x are vulnerable to Arbitrary Code Execution. The package fails to sanitize requests to the require-node endpoint, allowing attackers to execute arbitrary code in the server through the injection of OS commands in the request body. Recommendation - If you are using 1.x, upgrade to version 1.3.4 or later. - If you are using 2.x, upgrade to version 2.0.4 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8j6j-4h2c-c65p

  2. Revision 1 · created ·

    Published from osv record GHSA-8j6j-4h2c-c65p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8j6j-4h2c-c65p

Advisory: Arbitrary Code Execution in require-node
IDs: GHSA-8j6j-4h2c-c65p
Record: https://patchnext.com/advisories/ghsa-8j6j-4h2c-c65p (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: require-node 2.0.4, 1.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm require-node: affected < 1.3.4; >= 2.0.0, < 2.0.4; fixed in 2.0.4, 1.3.4

## Suggested inspection (read-only)
- `npm ls require-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on require-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8j6j-4h2c-c65p (OSV record GHSA-8j6j-4h2c-c65p lists affected ranges: npm require-node >=0 =2.0.0 <2.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8j6j-4h2c-c65p (GitHub-reviewed advisory GHSA-8j6j-4h2c-c65p lists affected ranges: npm require-node >=0 =2.0.0 <2.0.4)

Commands are suggestions: review each one before running it.

Loading voting…