Skip to content

← Public intelligence

npm package

react-dom

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting in react-dom

    CVE-2018-6341 · GHSA-mvjj-gqq2-p4hw

    Affected
    • npm react-dom >= 16.0.0, <= 16.0.0; >= 16.1.0, < 16.1.2; >= 16.2.0, <= 16.2.0; >= 16.3.0, < 16.3.3; >= 16.4.0, < 16.4.2
    Fixed in
    16.3.316.2.116.1.216.0.116.4.2· Vendor fix available
    Issue
    Affected versions of react-dom are vulnerable to Cross-Site Scripting (XSS). The package fails to validate attribute names in HTML tags which may lead to Cross-Site Scripting in specific scenarios. This may allow attackers to execute arbitrary JavaScript in the victim's browser. To be affected by this vulnerability, the application needs to: - be a server-side React app - be rendered to HTML using ReactDOMServer - include an attribute name from user input in an HTML tag Recommendation If you are using react-dom 16.0.x, upgrade to 16.0.1 or later. If you are using react-dom 16.1.x, upgrade to 16.1.2 or later. If you are using react-dom 16.2.x, upgrade to 16.2.1 or later. If you are using react-dom 16.3.x, upgrade to 16.3.3 or later. If you are using react-dom 16.4.x, upgrade to 16.4.2 or later.

    Recommended action: Upgrade to 16.4.2, 16.3.3, 16.2.1 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →