Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-Site Scripting in react-dom

CVE-2018-6341GHSA-mvjj-gqq2-p4hw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-dom 16.4.2, 16.3.3, 16.2.1, 16.1.2, 16.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-dom

    Affected
    >= 16.0.0, <= 16.0.0>= 16.1.0, < 16.1.2>= 16.2.0, <= 16.2.0>= 16.3.0, < 16.3.3>= 16.4.0, < 16.4.2
    Fixed in
    16.3.3, 16.2.1, 16.1.2, 16.0.1, 16.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-6341: 3.43% estimated exploitation activity in the next 30 days; percentile 88.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of react-dom are vulnerable to Cross-Site Scripting (XSS). The package fails to validate attribute names in HTML tags which may lead to Cross-Site Scripting in specific scenarios. This may allow attackers to execute arbitrary JavaScript in the victim's browser. To be affected by this vulnerability, the application needs to: - be a server-side React app - be rendered to HTML using ReactDOMServer - include an attribute name from user input in an HTML tag Recommendation If you are using react-dom 16.0.x, upgrade to 16.0.1 or later. If you are using react-dom 16.1.x, upgrade to 16.1.2 or later. If you are using react-dom 16.2.x, upgrade to 16.2.1 or later. If you are using react-dom 16.3.x, upgrade to 16.3.3 or later. If you are using react-dom 16.4.x, upgrade to 16.4.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mvjj-gqq2-p4hw

  2. Revision 1 · created ·

    Published from osv record GHSA-mvjj-gqq2-p4hw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-6341

Advisory: Cross-Site Scripting in react-dom
IDs: CVE-2018-6341, GHSA-mvjj-gqq2-p4hw
Record: https://patchnext.com/advisories/cve-2018-6341 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-dom 16.4.2, 16.3.3, 16.2.1, 16.1.2, 16.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-dom: affected >= 16.0.0, <= 16.0.0; >= 16.1.0, < 16.1.2; >= 16.2.0, <= 16.2.0; >= 16.3.0, < 16.3.3; >= 16.4.0, < 16.4.2; fixed in 16.3.3, 16.2.1, 16.1.2, 16.0.1, 16.4.2

## Suggested inspection (read-only)
- `npm ls react-dom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-dom.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mvjj-gqq2-p4hw (OSV record GHSA-mvjj-gqq2-p4hw lists affected ranges: npm react-dom >=16.0.0 =16.1.0 =16.2.0 =16.3.0 =16.4.0 <16.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mvjj-gqq2-p4hw (GitHub-reviewed advisory GHSA-mvjj-gqq2-p4hw lists affected ranges: npm react-dom >=16.0.0 =16.1.0 =16.2.0 =16.3.0 =16.4.0 <16.4.2)

Commands are suggestions: review each one before running it.

Loading voting…