Critical, CVSS 9.8npmAmendedPublished
Malicious Package in react-datepicker-plus
GHSA-4wcx-c9c4-89p2
- Affected
- npm react-datepicker-plus >= 2.4.2, <= 2.4.3
- Fixed in
- 2.4.6· Vendor fix available
- Issue
- Versions 2.4.3 and 2.4.2 of react-datepicker-plus contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 2.4.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.