Malicious Package in react-datepicker-plus
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-datepicker-plus 2.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.4.2, <= 2.4.3
- Fixed in
- 2.4.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4wcx-c9c4-89p2 lists affected ranges: npm react-datepicker-plus >=2.4.2 <2.4.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4wcx-c9c4-89p2 lists affected ranges: npm react-datepicker-plus >=2.4.2 <=2.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions 2.4.3 and 2.4.2 of react-datepicker-plus contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4wcx-c9c4-89p2
- Revision 1 · created ·
Published from osv record GHSA-4wcx-c9c4-89p2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4wcx-c9c4-89p2 Advisory: Malicious Package in react-datepicker-plus IDs: GHSA-4wcx-c9c4-89p2 Record: https://patchnext.com/advisories/ghsa-4wcx-c9c4-89p2 (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-datepicker-plus 2.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-datepicker-plus: affected >= 2.4.2, <= 2.4.3; fixed in 2.4.6 ## Suggested inspection (read-only) - `npm ls react-datepicker-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-datepicker-plus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4wcx-c9c4-89p2 (OSV record GHSA-4wcx-c9c4-89p2 lists affected ranges: npm react-datepicker-plus >=2.4.2 <2.4.6 (fixed)) - Verified: https://github.com/advisories/GHSA-4wcx-c9c4-89p2 (GitHub-reviewed advisory GHSA-4wcx-c9c4-89p2 lists affected ranges: npm react-datepicker-plus >=2.4.2 <=2.4.3) Commands are suggestions: review each one before running it.
Loading voting…