Critical, CVSS 9.8npmAmendedPublished
Malicious Package in rate-map
GHSA-x48m-gp6r-gp4v
- Affected
- npm rate-map >= 1.0.3, <= 1.0.3
- Fixed in
- 1.0.5· Vendor fix available
- Issue
- Version 1.0.3 of rate-map contains malicious code. The malware breaks functionality of the purescript-installer package by rewriting code of the dl-tar dependency. Recommendation Upgrade to version 1.0.5 or later. There is no indication of further compromise.
Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.