Malicious Package in rate-map
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rate-map 1.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm rate-map
- Affected
- >= 1.0.3, <= 1.0.3
- Fixed in
- 1.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x48m-gp6r-gp4v lists affected ranges: npm rate-map >=1.0.3 <1.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x48m-gp6r-gp4v lists affected ranges: npm rate-map >=1.0.3 <=1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Version 1.0.3 of rate-map contains malicious code. The malware breaks functionality of the purescript-installer package by rewriting code of the dl-tar dependency. Recommendation Upgrade to version 1.0.5 or later. There is no indication of further compromise.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x48m-gp6r-gp4v
- Revision 1 · created ·
Published from osv record GHSA-x48m-gp6r-gp4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-x48m-gp6r-gp4v Advisory: Malicious Package in rate-map IDs: GHSA-x48m-gp6r-gp4v Record: https://patchnext.com/advisories/ghsa-x48m-gp6r-gp4v (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rate-map 1.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm rate-map: affected >= 1.0.3, <= 1.0.3; fixed in 1.0.5 ## Suggested inspection (read-only) - `npm ls rate-map --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rate-map. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x48m-gp6r-gp4v (OSV record GHSA-x48m-gp6r-gp4v lists affected ranges: npm rate-map >=1.0.3 <1.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-x48m-gp6r-gp4v (GitHub-reviewed advisory GHSA-x48m-gp6r-gp4v lists affected ranges: npm rate-map >=1.0.3 <=1.0.3) Commands are suggestions: review each one before running it.
Loading voting…