Critical, CVSS 9.8npmAmendedPublished
Potential Command Injection in printer
CVE-2014-3741 · GHSA-5c8j-xr24-2665
- Affected
- npm printer <= 0.0.1
- Fixed in
- 0.0.2· Vendor fix available
- Issue
- Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function. Recommendation Update to version 0.0.2 or later.
Recommended action: Upgrade to 0.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.