Potential Command Injection in printer
CVE-2014-3741GHSA-5c8j-xr24-2665
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (printer 0.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm printer
- Affected
- <= 0.0.1
- Fixed in
- 0.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5c8j-xr24-2665 lists affected ranges: npm printer >=0 <0.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5c8j-xr24-2665 lists affected ranges: npm printer >=0 <=0.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2014-3741: 3.76% estimated exploitation activity in the next 30 days; percentile 89.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function. Recommendation Update to version 0.0.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5c8j-xr24-2665
- Revision 1 · created ·
Published from osv record GHSA-5c8j-xr24-2665
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3741 Advisory: Potential Command Injection in printer IDs: CVE-2014-3741, GHSA-5c8j-xr24-2665 Record: https://patchnext.com/advisories/cve-2014-3741 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: printer 0.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm printer: affected <= 0.0.1; fixed in 0.0.2 ## Suggested inspection (read-only) - `npm ls printer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on printer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5c8j-xr24-2665 (OSV record GHSA-5c8j-xr24-2665 lists affected ranges: npm printer >=0 <0.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5c8j-xr24-2665 (GitHub-reviewed advisory GHSA-5c8j-xr24-2665 lists affected ranges: npm printer >=0 <=0.0.1) Commands are suggestions: review each one before running it.
Loading voting…