Skip to content

← Public intelligence

npm package

plotly.js

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    plotly.js prototype pollution vulnerability

    CVE-2023-46308 · GHSA-wjc4-73q6-gv3m

    Affected
    • npm plotly.js < 2.25.2
    Fixed in
    2.25.2· Vendor fix available
    Issue
    In Plotly plotly.js before 2.25.2, plot API calls have a risk of proto being polluted in expandObjectPaths or nestedProperty.

    Recommended action: Upgrade to 2.25.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Cross Site Scripting (XSS) in plotly.js

    CVE-2017-1000006 · GHSA-2fqv-h3r5-m4vf

    Affected
    • npm plotly.js < 1.16.0
    Fixed in
    1.16.0· Vendor fix available
    Issue
    Affected versions of plotly.js are vulnerable to cross-site scripting if an attacker can convince a user to visit a malicious plot on a site using this package. Recommendation Update to 1.16.0 or later.

    Recommended action: Upgrade to 1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →