Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross Site Scripting (XSS) in plotly.js

CVE-2017-1000006GHSA-2fqv-h3r5-m4vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plotly.js 1.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-1000006: 0.88% estimated exploitation activity in the next 30 days; percentile 59.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of plotly.js are vulnerable to cross-site scripting if an attacker can convince a user to visit a malicious plot on a site using this package. Recommendation Update to 1.16.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2fqv-h3r5-m4vf

  2. Revision 1 · created ·

    Published from osv record GHSA-2fqv-h3r5-m4vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000006

Advisory: Cross Site Scripting (XSS) in plotly.js
IDs: CVE-2017-1000006, GHSA-2fqv-h3r5-m4vf
Record: https://patchnext.com/advisories/cve-2017-1000006 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plotly.js 1.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm plotly.js: affected < 1.16.0; fixed in 1.16.0

## Suggested inspection (read-only)
- `npm ls plotly.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plotly.js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2fqv-h3r5-m4vf (OSV record GHSA-2fqv-h3r5-m4vf lists affected ranges: npm plotly.js >=0 <1.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2fqv-h3r5-m4vf (GitHub-reviewed advisory GHSA-2fqv-h3r5-m4vf lists affected ranges: npm plotly.js >=0 <1.16.0)

Commands are suggestions: review each one before running it.

Loading voting…