Skip to content

← Public intelligence

npm package

pidusage

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    PIDUsage Enables OS Command Injection

    CVE-2017-1000220 · GHSA-h2p3-h48h-9jj7

    Affected
    • npm pidusage <= 1.1.4
    Fixed in
    1.1.5· Vendor fix available
    Issue
    Affected versions of pidusage pass unsanitized input to childprocess.exec(), resulting in arbitrary code execution in the ps method. This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX. Windows and Linux are not vulnerable. Proof of Concept Remediation Update to version 1.1.5 or later.

    Recommended action: Upgrade to 1.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Command Injection in pidusage

    CVE-2017-16034 · GHSA-hfq9-rfpv-j8r8

    Affected
    • npm pidusage <= 1.1.4
    Fixed in
    1.1.5· Vendor fix available
    Issue
    Affected versions of pidusage pass unsanitized input to childprocess.exec(), resulting in arbitrary code execution in the ps method. This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX. Windows and Linux are not vulnerable. Proof of Concept Recommendation Update to version 1.1.5 or later.

    Recommended action: Upgrade to 1.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →