PIDUsage Enables OS Command Injection
CVE-2017-1000220GHSA-h2p3-h48h-9jj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pidusage 1.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pidusage
- Affected
- <= 1.1.4
- Fixed in
- 1.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h2p3-h48h-9jj7 lists affected ranges: npm pidusage >=0 <1.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h2p3-h48h-9jj7 lists affected ranges: npm pidusage >=0 <=1.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000220: 5.06% estimated exploitation activity in the next 30 days; percentile 92.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Affected versions of pidusage pass unsanitized input to childprocess.exec(), resulting in arbitrary code execution in the ps method. This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX. Windows and Linux are not vulnerable. Proof of Concept Remediation Update to version 1.1.5 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h2p3-h48h-9jj7
- Revision 1 · created ·
Published from osv record GHSA-h2p3-h48h-9jj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000220 Advisory: PIDUsage Enables OS Command Injection IDs: CVE-2017-1000220, GHSA-h2p3-h48h-9jj7 Record: https://patchnext.com/advisories/cve-2017-1000220 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pidusage 1.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pidusage: affected <= 1.1.4; fixed in 1.1.5 ## Suggested inspection (read-only) - `npm ls pidusage --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pidusage. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h2p3-h48h-9jj7 (OSV record GHSA-h2p3-h48h-9jj7 lists affected ranges: npm pidusage >=0 <1.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-h2p3-h48h-9jj7 (GitHub-reviewed advisory GHSA-h2p3-h48h-9jj7 lists affected ranges: npm pidusage >=0 <=1.1.4) Commands are suggestions: review each one before running it.
Loading voting…