Skip to content

← Public intelligence

npm package

nunjucks

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Nunjucks autoescape bypass leads to cross site scripting

    CVE-2023-2142 · GHSA-x77j-w7wf-fjmw

    Affected
    • npm nunjucks < 3.2.4
    Fixed in
    3.2.4· Vendor fix available
    Issue
    Impact In Nunjucks versions prior to version 3.2.4, it was possible to bypass the restrictions which are provided by the autoescape functionality. If there are two user-controlled parameters on the same line used in the views, it was possible to inject cross site scripting payloads using the backslash \ character. Example If the user-controlled parameters were used in the views similar to the following: It is possible to inject XSS payload using the below parameters: Patches The issue was patched in version 3.2.4. References - https://bugzilla.mozilla.org/showbug.cgi?id=1825980

    Recommended action: Upgrade to 3.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in nunjucks

    CVE-2016-10547 · GHSA-f7ph-p5rv-phw2

    Affected
    • npm nunjucks < 2.4.3
    Fixed in
    2.4.3· Vendor fix available
    Issue
    Affected versions of nunjucks do not properly escape specially structured user input in template vars when in auto-escape mode, resulting in a cross-site scripting vulnerability. Proof of Concept By using an array for the keys in a template var, escaping is bypassed. A full PoC is available in the references section. Recommendation Update to version 2.4.3 or later.

    Recommended action: Upgrade to 2.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →