Nunjucks autoescape bypass leads to cross site scripting
CVE-2023-2142GHSA-x77j-w7wf-fjmw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nunjucks 3.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nunjucks
- Affected
- < 3.2.4
- Fixed in
- 3.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x77j-w7wf-fjmw lists affected ranges: npm nunjucks >=0 <3.2.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x77j-w7wf-fjmw lists affected ranges: npm nunjucks >=0 <3.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-2142: 0.36% estimated exploitation activity in the next 30 days; percentile 30.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In Nunjucks versions prior to version 3.2.4, it was possible to bypass the restrictions which are provided by the autoescape functionality. If there are two user-controlled parameters on the same line used in the views, it was possible to inject cross site scripting payloads using the backslash \ character. Example If the user-controlled parameters were used in the views similar to the following: It is possible to inject XSS payload using the below parameters: Patches The issue was patched in version 3.2.4. References - https://bugzilla.mozilla.org/showbug.cgi?id=1825980
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x77j-w7wf-fjmw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x77j-w7wf-fjmw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-2142 Advisory: Nunjucks autoescape bypass leads to cross site scripting IDs: CVE-2023-2142, GHSA-x77j-w7wf-fjmw Record: https://patchnext.com/advisories/cve-2023-2142 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nunjucks 3.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nunjucks: affected < 3.2.4; fixed in 3.2.4 ## Suggested inspection (read-only) - `npm ls nunjucks --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nunjucks. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x77j-w7wf-fjmw (OSV record GHSA-x77j-w7wf-fjmw lists affected ranges: npm nunjucks >=0 <3.2.4 (fixed)) - Verified: https://github.com/advisories/GHSA-x77j-w7wf-fjmw (GitHub-reviewed advisory GHSA-x77j-w7wf-fjmw lists affected ranges: npm nunjucks >=0 <3.2.4) Commands are suggestions: review each one before running it.
Loading voting…