Critical, CVSS 9.8npmAmendedPublished
OS Command injection in npm-lockfile
CVE-2022-0841 · GHSA-cr6m-62pq-hmqh
- Affected
- npm npm-lockfile >= 2.0.3, < 2.0.5
- Fixed in
- 2.0.5· Vendor fix available
- Issue
- npm-lockfile safely generates an npm lockfile and output it to the filename of your choice. npm-lockfile before 2.0.4 does not santize unsafe external input and invoke sensitive command execution API with the input, causing command injection vulnerability. A fix was released in version 2.0.5.
Recommended action: Upgrade to 2.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.