OS Command injection in npm-lockfile
CVE-2022-0841GHSA-cr6m-62pq-hmqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (npm-lockfile 2.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm npm-lockfile
- Affected
- >= 2.0.3, < 2.0.5
- Fixed in
- 2.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cr6m-62pq-hmqh lists affected ranges: npm npm-lockfile >=2.0.3 <2.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cr6m-62pq-hmqh lists affected ranges: npm npm-lockfile >=2.0.3 <2.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-0841: 2.51% estimated exploitation activity in the next 30 days; percentile 84.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
npm-lockfile safely generates an npm lockfile and output it to the filename of your choice. npm-lockfile before 2.0.4 does not santize unsafe external input and invoke sensitive command execution API with the input, causing command injection vulnerability. A fix was released in version 2.0.5.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cr6m-62pq-hmqh
- Revision 1 · created ·
Published from osv record GHSA-cr6m-62pq-hmqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0841 Advisory: OS Command injection in npm-lockfile IDs: CVE-2022-0841, GHSA-cr6m-62pq-hmqh Record: https://patchnext.com/advisories/cve-2022-0841 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: npm-lockfile 2.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm npm-lockfile: affected >= 2.0.3, < 2.0.5; fixed in 2.0.5 ## Suggested inspection (read-only) - `npm ls npm-lockfile --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on npm-lockfile. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cr6m-62pq-hmqh (OSV record GHSA-cr6m-62pq-hmqh lists affected ranges: npm npm-lockfile >=2.0.3 <2.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-cr6m-62pq-hmqh (GitHub-reviewed advisory GHSA-cr6m-62pq-hmqh lists affected ranges: npm npm-lockfile >=2.0.3 <2.0.5) Commands are suggestions: review each one before running it.
Loading voting…