Skip to content

← Public intelligence

npm package

node-sass

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Improper Certificate Validation in node-sass

    CVE-2020-24025 · GHSA-r8f7-9pfq-mjmv

    Affected
    • npm node-sass >= 2.0.0, < 7.0.0
    Fixed in
    7.0.0· Vendor fix available
    Issue
    Certificate validation in node-sass 2.0.0 to 6.0.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

    Recommended action: Upgrade to 7.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.9npmAmendedPublished

    Denial of Service in node-sass

    GHSA-9v62-24cr-58cx

    Affected
    • npm node-sass >= 3.3.0, < 4.13.1
    Fixed in
    4.13.1· Vendor fix available
    Issue
    Affected versions of node-sass are vulnerable to Denial of Service (DoS). Crafted objects passed to the renderSync function may trigger C++ assertions in CustomImporterBridge::getimporterentry and CustomImporterBridge::postprocessreturnvalue that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service. Recommendation Upgrade to version 4.13.1 or later

    Recommended action: Upgrade to 4.13.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →