Skip to content

← Actionable
Medium, CVSS 5.9amended

Denial of Service in node-sass

GHSA-9v62-24cr-58cx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-sass 4.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm node-sass

    Affected
    >= 3.3.0, < 4.13.1
    Fixed in
    4.13.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions of node-sass are vulnerable to Denial of Service (DoS). Crafted objects passed to the renderSync function may trigger C++ assertions in CustomImporterBridge::getimporterentry and CustomImporterBridge::postprocessreturnvalue that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service. Recommendation Upgrade to version 4.13.1 or later

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9v62-24cr-58cx

  2. Revision 1 · created ·

    Published from osv record GHSA-9v62-24cr-58cx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9v62-24cr-58cx

Advisory: Denial of Service in node-sass
IDs: GHSA-9v62-24cr-58cx
Record: https://patchnext.com/advisories/ghsa-9v62-24cr-58cx (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-sass 4.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-sass: affected >= 3.3.0, < 4.13.1; fixed in 4.13.1

## Suggested inspection (read-only)
- `npm ls node-sass --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-sass.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9v62-24cr-58cx (OSV record GHSA-9v62-24cr-58cx lists affected ranges: npm node-sass >=3.3.0 <4.13.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9v62-24cr-58cx (GitHub-reviewed advisory GHSA-9v62-24cr-58cx lists affected ranges: npm node-sass >=3.3.0 <4.13.1)

Commands are suggestions: review each one before running it.

Loading voting…