High, CVSS 8.2npmAmendedPublished
node-opcua-alarm-condition prototype pollution vulnerability
CVE-2024-57086 · GHSA-gvwq-6fmx-28xm
- Affected
- npm node-opcua-alarm-condition < 2.137.0
- Fixed in
- 2.137.0· Vendor fix available
- Issue
- A prototype pollution in the function fieldsToJson of node-opcua-alarm-condition v2.134.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.
Recommended action: Upgrade to 2.137.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.