node-opcua-alarm-condition prototype pollution vulnerability
CVE-2024-57086GHSA-gvwq-6fmx-28xm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-opcua-alarm-condition 2.137.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-opcua-alarm-condition
- Affected
- < 2.137.0
- Fixed in
- 2.137.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gvwq-6fmx-28xm lists affected ranges: npm node-opcua-alarm-condition >=0 <2.137.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gvwq-6fmx-28xm lists affected ranges: npm node-opcua-alarm-condition >=0 <2.137.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2024-57086: 0.44% estimated exploitation activity in the next 30 days; percentile 38.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A prototype pollution in the function fieldsToJson of node-opcua-alarm-condition v2.134.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gvwq-6fmx-28xm
- Revision 1 · created ·
Published from osv record GHSA-gvwq-6fmx-28xm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-57086 Advisory: node-opcua-alarm-condition prototype pollution vulnerability IDs: CVE-2024-57086, GHSA-gvwq-6fmx-28xm Record: https://patchnext.com/advisories/cve-2024-57086 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-opcua-alarm-condition 2.137.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-opcua-alarm-condition: affected < 2.137.0; fixed in 2.137.0 ## Suggested inspection (read-only) - `npm ls node-opcua-alarm-condition --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-opcua-alarm-condition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gvwq-6fmx-28xm (OSV record GHSA-gvwq-6fmx-28xm lists affected ranges: npm node-opcua-alarm-condition >=0 <2.137.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gvwq-6fmx-28xm (GitHub-reviewed advisory GHSA-gvwq-6fmx-28xm lists affected ranges: npm node-opcua-alarm-condition >=0 <2.137.0) Commands are suggestions: review each one before running it.
Loading voting…