High, CVSS 7.5Exploited · CISA KEVnpmAmendedPublished
eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code
CVE-2025-54313 · GHSA-f29h-pxvx-f335
- Affected
- npm napi-postinstall >= 0.3.1, <= 0.3.1
- Fixed in
- 0.3.2· Vendor fix available
- Issue
- eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.
Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.