Skip to content

← Actionable
High, CVSS 7.5Exploited · CISA KEVamended

eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

CVE-2025-54313GHSA-f29h-pxvx-f335

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (napi-postinstall 0.3.2; eslint-config-prettier 10.1.8, 9.1.2, 8.10.2; @pkgr/core 0.2.9; synckit 0.11.10; eslint-plugin-prettier 4.2.4; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2025-54313: 5.13% estimated exploitation activity in the next 30 days; percentile 92.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f29h-pxvx-f335

  2. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2025-54313 (date added 2026-01-22). Customer workflow unchanged.

  3. Revision 1 · created ·

    Published from osv record GHSA-f29h-pxvx-f335

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54313

Advisory: eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code
IDs: CVE-2025-54313, GHSA-f29h-pxvx-f335
Record: https://patchnext.com/advisories/cve-2025-54313 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: napi-postinstall 0.3.2; eslint-config-prettier 10.1.8, 9.1.2, 8.10.2; @pkgr/core 0.2.9; synckit 0.11.10; eslint-plugin-prettier 4.2.4; got-fetch 6.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm napi-postinstall: affected >= 0.3.1, <= 0.3.1; fixed in 0.3.2
- npm eslint-config-prettier: affected >= 8.10.1, <= 8.10.1; >= 9.1.1, <= 9.1.1; >= 10.1.6, <= 10.1.7; fixed in 8.10.2, 10.1.8, 9.1.2
- npm @pkgr/core: affected >= 0.2.8, <= 0.2.8; fixed in 0.2.9
- npm synckit: affected >= 0.11.9, <= 0.11.9; fixed in 0.11.10
- npm eslint-plugin-prettier: affected >= 4.2.2, <= 4.2.3; fixed in 4.2.4
- npm got-fetch: affected >= 5.1.11, <= 5.1.12; fixed in 6.0.0

## Suggested inspection (read-only)
- `npm ls napi-postinstall --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls eslint-config-prettier --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @pkgr/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls synckit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls eslint-plugin-prettier --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls got-fetch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on napi-postinstall, eslint-config-prettier, @pkgr/core, synckit, eslint-plugin-prettier, got-fetch.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f29h-pxvx-f335 (OSV record GHSA-f29h-pxvx-f335 lists affected ranges: npm eslint-config-prettier >=8.10.1 =9.1.1 =10.1.6 =4.2.2 =0.11.9 =0.2.8 =0.3.1 =5.1.11 <6.0.0 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2025-54313 to the Known Exploited Vulnerabilities catalog on 2026-01-22.)
- Verified: https://github.com/advisories/GHSA-f29h-pxvx-f335 (GitHub-reviewed advisory GHSA-f29h-pxvx-f335 lists affected ranges: npm eslint-config-prettier >=8.10.1 =9.1.1 =10.1.6 =4.2.2 =0.11.9 =0.2.8 =0.3.1 =5.1.11 <=5.1.12)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-54313 to the Known Exploited Vulnerabilities catalog on 2026-01-22.)

Commands are suggestions: review each one before running it.

Loading voting…