Skip to content

← Public intelligence

npm package

msrcrypto

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    Incorrect Calculation in the MSR JavaScript Cryptography Library

    CVE-2020-1026 · GHSA-9x9j-836w-8f55

    Affected
    • npm msrcrypto < 1.5.8
    Fixed in
    1.5.8· Vendor fix available
    Issue
    A Security Feature Bypass vulnerability exists in the MSR JavaScript Cryptography Library that is caused by multiple bugs in the library's Elliptic Curve Cryptography (ECC) implementation.An attacker could potentially abuse these bugs to learn information about a server's private ECC key (a key leakage attack) or craft an invalid ECDSA signature that nevertheless passes as valid.The security update addresses the vulnerability by fixing the bugs disclosed in the ECC implementation, aka MSR JavaScript Cryptography Library Security Feature Bypass Vulnerability.

    Recommended action: Upgrade to 1.5.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Sensitive Data Exposure in msrcrypto

    CVE-2018-8319 · GHSA-qg3g-2mgh-33j8

    Affected
    • npm msrcrypto < 1.4.1
    Fixed in
    1.4.1· Vendor fix available
    Issue
    Versions of msrcrypto prior to 1.4.1 are vulnerable to Sensitive Data Exposure. The package's Elliptic Curve Cryptography (ECC) implementation may leak information about a server's private ECC key. It can also allow attackers to craft invalid ECDSA signatures that pass as valid. There is no published proof-of-concept for this vulnerability. Recommendation Upgrade to version 1.4.1 or later.

    Recommended action: Upgrade to 1.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →