Skip to content

← Actionable
Critical, CVSS 9.8amended

Incorrect Calculation in the MSR JavaScript Cryptography Library

CVE-2020-1026GHSA-9x9j-836w-8f55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (msrcrypto 1.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-1026: 2.60% estimated exploitation activity in the next 30 days; percentile 85.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Security Feature Bypass vulnerability exists in the MSR JavaScript Cryptography Library that is caused by multiple bugs in the library's Elliptic Curve Cryptography (ECC) implementation.An attacker could potentially abuse these bugs to learn information about a server's private ECC key (a key leakage attack) or craft an invalid ECDSA signature that nevertheless passes as valid.The security update addresses the vulnerability by fixing the bugs disclosed in the ECC implementation, aka MSR JavaScript Cryptography Library Security Feature Bypass Vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9x9j-836w-8f55

  2. Revision 1 · created ·

    Published from osv record GHSA-9x9j-836w-8f55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1026

Advisory: Incorrect Calculation in the MSR JavaScript Cryptography Library
IDs: CVE-2020-1026, GHSA-9x9j-836w-8f55
Record: https://patchnext.com/advisories/cve-2020-1026 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: msrcrypto 1.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm msrcrypto: affected < 1.5.8; fixed in 1.5.8

## Suggested inspection (read-only)
- `npm ls msrcrypto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on msrcrypto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9x9j-836w-8f55 (OSV record GHSA-9x9j-836w-8f55 lists affected ranges: npm msrcrypto >=0 <1.5.8 (fixed))
- Verified: https://github.com/advisories/GHSA-9x9j-836w-8f55 (GitHub-reviewed advisory GHSA-9x9j-836w-8f55 lists affected ranges: npm msrcrypto >=0 <1.5.8)

Commands are suggestions: review each one before running it.

Loading voting…