High, CVSS 7.5npmAmendedPublished
mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input
CVE-2017-16138 · GHSA-wrvr-8mpx-r7pp
- Affected
- npm mime < 1.4.1; >= 2.0.0, < 2.0.3
- Fixed in
- 2.0.31.4.1· Vendor fix available
- Issue
- Affected versions of mime are vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input. Recommendation Update to version 2.0.3 or later.
Recommended action: Upgrade to 2.0.3 or 1.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.