mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input
CVE-2017-16138GHSA-wrvr-8mpx-r7pp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mime 2.0.3, 1.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mime
- Affected
- < 1.4.1>= 2.0.0, < 2.0.3
- Fixed in
- 2.0.3, 1.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wrvr-8mpx-r7pp lists affected ranges: npm mime >=2.0.0 =0 <1.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wrvr-8mpx-r7pp lists affected ranges: npm mime >=0 =2.0.0 <2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-16138: 2.12% estimated exploitation activity in the next 30 days; percentile 81.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of mime are vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input. Recommendation Update to version 2.0.3 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wrvr-8mpx-r7pp
- Revision 1 · created ·
Published from osv record GHSA-wrvr-8mpx-r7pp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16138 Advisory: mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input IDs: CVE-2017-16138, GHSA-wrvr-8mpx-r7pp Record: https://patchnext.com/advisories/cve-2017-16138 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mime 2.0.3, 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mime: affected < 1.4.1; >= 2.0.0, < 2.0.3; fixed in 2.0.3, 1.4.1 ## Suggested inspection (read-only) - `npm ls mime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wrvr-8mpx-r7pp (OSV record GHSA-wrvr-8mpx-r7pp lists affected ranges: npm mime >=2.0.0 =0 <1.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-wrvr-8mpx-r7pp (GitHub-reviewed advisory GHSA-wrvr-8mpx-r7pp lists affected ranges: npm mime >=0 =2.0.0 <2.0.3) Commands are suggestions: review each one before running it.
Loading voting…