High, CVSS 7.5npmAmendedPublished
method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header
CVE-2017-16136 · GHSA-qx2f-477c-35rq
- Affected
- npm method-override >= 1.0.2, <= 1.0.2; >= 2.0.0, < 2.3.10
- Fixed in
- 2.3.10· Vendor fix available
- Issue
- Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header. Recommendation Update to version 2.3.10 or later
Recommended action: Upgrade to 2.3.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.