Skip to content

← Actionable
High, CVSS 7.5amended

method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header

CVE-2017-16136GHSA-qx2f-477c-35rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (method-override 2.3.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm method-override

    Affected
    >= 1.0.2, <= 1.0.2>= 2.0.0, < 2.3.10
    Fixed in
    2.3.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2017-16136: 1.20% estimated exploitation activity in the next 30 days; percentile 68.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header. Recommendation Update to version 2.3.10 or later

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qx2f-477c-35rq

  2. Revision 1 · created ·

    Published from osv record GHSA-qx2f-477c-35rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16136

Advisory: method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header
IDs: CVE-2017-16136, GHSA-qx2f-477c-35rq
Record: https://patchnext.com/advisories/cve-2017-16136 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: method-override 2.3.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm method-override: affected >= 1.0.2, <= 1.0.2; >= 2.0.0, < 2.3.10; fixed in 2.3.10

## Suggested inspection (read-only)
- `npm ls method-override --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on method-override.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qx2f-477c-35rq (OSV record GHSA-qx2f-477c-35rq lists affected ranges: npm method-override >=1.0.2 =2.0.0 <2.3.10 (fixed))
- Verified: https://github.com/advisories/GHSA-qx2f-477c-35rq (GitHub-reviewed advisory GHSA-qx2f-477c-35rq lists affected ranges: npm method-override >=1.0.2 =2.0.0 <2.3.10)

Commands are suggestions: review each one before running it.

Loading voting…