Critical, CVSS 9.6npmAmendedPublished
mcp-remote exposed to OS command injection via untrusted MCP server connections
CVE-2025-6514 · GHSA-6xpm-ggf7-wc3p
- Affected
- npm mcp-remote >= 0.0.5, < 0.1.16
- Fixed in
- 0.1.16· Vendor fix available
- Issue
- mcp-remote is exposed to OS command injection when connecting to untrusted MCP servers due to crafted input from the authorizationendpoint response URL
Recommended action: Upgrade to 0.1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.