Skip to content

← Actionable
Critical, CVSS 9.6amended

mcp-remote exposed to OS command injection via untrusted MCP server connections

CVE-2025-6514GHSA-6xpm-ggf7-wc3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-remote 0.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mcp-remote

    Affected
    >= 0.0.5, < 0.1.16
    Fixed in
    0.1.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-6514: 77.03% estimated exploitation activity in the next 30 days; percentile 99.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

mcp-remote is exposed to OS command injection when connecting to untrusted MCP servers due to crafted input from the authorizationendpoint response URL

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6xpm-ggf7-wc3p

  2. Revision 1 · created ·

    Published from osv record GHSA-6xpm-ggf7-wc3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6514

Advisory: mcp-remote exposed to OS command injection via untrusted MCP server connections
IDs: CVE-2025-6514, GHSA-6xpm-ggf7-wc3p
Record: https://patchnext.com/advisories/cve-2025-6514 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-remote 0.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mcp-remote: affected >= 0.0.5, < 0.1.16; fixed in 0.1.16

## Suggested inspection (read-only)
- `npm ls mcp-remote --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-remote.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6xpm-ggf7-wc3p (OSV record GHSA-6xpm-ggf7-wc3p lists affected ranges: npm mcp-remote >=0.0.5 <0.1.16 (fixed))
- Verified: https://github.com/advisories/GHSA-6xpm-ggf7-wc3p (GitHub-reviewed advisory GHSA-6xpm-ggf7-wc3p lists affected ranges: npm mcp-remote >=0.0.5 <0.1.16)

Commands are suggestions: review each one before running it.

Loading voting…