Skip to content

← Public intelligence

npm package

m-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Path Traversal in m-server

    GHSA-vc6r-4x6g-mmqc

    Affected
    • npm m-server < 1.4.2
    Fixed in
    1.4.2· Vendor fix available
    Issue
    Versions of m-server before 1.4.2 are vulnerable to path traversal allowing a remote attacker to display content of arbitrary files from the server. Recommendation Update to version 1.4.2 or later.

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.5npmAmendedPublished

    m-server Vulnerable to Directory Traversal

    CVE-2018-16485 · GHSA-899g-6q6w-7v94

    Affected
    • npm m-server < 1.4.1
    Fixed in
    1.4.1· Vendor fix available
    Issue
    Path Traversal vulnerability in module m-server <1.4.1 allows malicious user to access unauthorized content of any file in the directory tree e.g. /etc/passwd by appending slashes to the URL request.

    Recommended action: Upgrade to 1.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.4npmAmendedPublished

    Cross-Site Scripting in m-server

    CVE-2018-16484 · GHSA-gmxv-xf2q-6j8m

    Affected
    • npm m-server < 1.4.2
    Fixed in
    1.4.2· Vendor fix available
    Issue
    Versions of m-server before 1.4.2 are vulnerable to stored cross-site scripting. This vulnerability is exploitable if an attacker is able to control the name of a file that m-server is serving. Recommendation Update to version 1.4.2 or later.

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →