Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-Site Scripting in m-server

CVE-2018-16484GHSA-gmxv-xf2q-6j8m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (m-server 1.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm m-server

    Affected
    < 1.4.2
    Fixed in
    1.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-16484: 0.61% estimated exploitation activity in the next 30 days; percentile 49.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of m-server before 1.4.2 are vulnerable to stored cross-site scripting. This vulnerability is exploitable if an attacker is able to control the name of a file that m-server is serving. Recommendation Update to version 1.4.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gmxv-xf2q-6j8m

  2. Revision 1 · created ·

    Published from osv record GHSA-gmxv-xf2q-6j8m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-16484

Advisory: Cross-Site Scripting in m-server
IDs: CVE-2018-16484, GHSA-gmxv-xf2q-6j8m
Record: https://patchnext.com/advisories/cve-2018-16484 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: m-server 1.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm m-server: affected < 1.4.2; fixed in 1.4.2

## Suggested inspection (read-only)
- `npm ls m-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on m-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gmxv-xf2q-6j8m (OSV record GHSA-gmxv-xf2q-6j8m lists affected ranges: npm m-server >=0 <1.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-gmxv-xf2q-6j8m (GitHub-reviewed advisory GHSA-gmxv-xf2q-6j8m lists affected ranges: npm m-server >=0 <1.4.2)

Commands are suggestions: review each one before running it.

Loading voting…