Skip to content

← Public intelligence

npm package

loader-utils

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    loader-utils is vulnerable to Regular Expression Denial of Service (ReDoS) via url variable

    CVE-2022-37603 · GHSA-3rfm-jhwj-7488

    Affected
    • npm loader-utils >= 1.0.0, < 1.4.2; >= 2.0.0, < 2.0.4; >= 3.0.0, < 3.2.1
    Fixed in
    1.4.23.2.12.0.4· Vendor fix available
    Issue
    A Regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils 2.0.0 via the url variable in interpolateName.js. A badly or maliciously formed string could be used to send crafted requests that cause a system to crash or take a disproportional amount of time to process. This issue has been patched in versions 1.4.2, 2.0.4 and 3.2.1.

    Recommended action: Upgrade to 3.2.1, 2.0.4 or 1.4.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Prototype pollution in webpack loader-utils

    CVE-2022-37601 · GHSA-76p3-8jx3-jpfq

    Affected
    • npm loader-utils >= 2.0.0, < 2.0.3; < 1.4.1
    Fixed in
    2.0.31.4.1· Vendor fix available
    Issue
    Prototype pollution vulnerability in function parseQuery in parseQuery.js in webpack loader-utils prior to version 2.0.3 via the name variable in parseQuery.js.

    Recommended action: Upgrade to 2.0.3 or 1.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    loader-utils is vulnerable to Regular Expression Denial of Service (ReDoS)

    CVE-2022-37599 · GHSA-hhq3-ff78-jv3g

    Affected
    • npm loader-utils >= 1.0.0, < 1.4.2; >= 2.0.0, < 2.0.4; >= 3.0.0, < 3.2.1
    Fixed in
    1.4.23.2.12.0.4· Vendor fix available
    Issue
    A regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils via the resourcePath variable in interpolateName.js. A badly or maliciously formed string could be used to send crafted requests that cause a system to crash or take a disproportional amount of time to process. This issue has been patched in versions 1.4.2, 2.0.4 and 3.2.1.

    Recommended action: Upgrade to 3.2.1, 2.0.4 or 1.4.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →