loader-utils is vulnerable to Regular Expression Denial of Service (ReDoS)
CVE-2022-37599GHSA-hhq3-ff78-jv3g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (loader-utils 3.2.1, 2.0.4, 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm loader-utils
- Affected
- >= 1.0.0, < 1.4.2>= 2.0.0, < 2.0.4>= 3.0.0, < 3.2.1
- Fixed in
- 1.4.2, 3.2.1, 2.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hhq3-ff78-jv3g lists affected ranges: npm loader-utils >=1.0.0 =2.0.0 =3.0.0 <3.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhq3-ff78-jv3g lists affected ranges: npm loader-utils >=1.0.0 =2.0.0 =3.0.0 <3.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-37599: 2.76% estimated exploitation activity in the next 30 days; percentile 86.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils via the resourcePath variable in interpolateName.js. A badly or maliciously formed string could be used to send crafted requests that cause a system to crash or take a disproportional amount of time to process. This issue has been patched in versions 1.4.2, 2.0.4 and 3.2.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hhq3-ff78-jv3g
- Revision 1 · created ·
Published from osv record GHSA-hhq3-ff78-jv3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-37599 Advisory: loader-utils is vulnerable to Regular Expression Denial of Service (ReDoS) IDs: CVE-2022-37599, GHSA-hhq3-ff78-jv3g Record: https://patchnext.com/advisories/cve-2022-37599 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: loader-utils 3.2.1, 2.0.4, 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm loader-utils: affected >= 1.0.0, < 1.4.2; >= 2.0.0, < 2.0.4; >= 3.0.0, < 3.2.1; fixed in 1.4.2, 3.2.1, 2.0.4 ## Suggested inspection (read-only) - `npm ls loader-utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on loader-utils. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hhq3-ff78-jv3g (OSV record GHSA-hhq3-ff78-jv3g lists affected ranges: npm loader-utils >=1.0.0 =2.0.0 =3.0.0 <3.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hhq3-ff78-jv3g (GitHub-reviewed advisory GHSA-hhq3-ff78-jv3g lists affected ranges: npm loader-utils >=1.0.0 =2.0.0 =3.0.0 <3.2.1) Commands are suggestions: review each one before running it.
Loading voting…