Critical, CVSS 9.8npmAmendedPublished
Potential Command Injection in libnotify
CVE-2013-7381 · GHSA-6898-wx94-8jq8
- Affected
- npm libnotify <= 1.0.3
- Fixed in
- 1.0.4· Vendor fix available
- Issue
- Versions 1.0.3 and earlier of libnotify are affected by a shell command injection vulnerability. This may result in execution of arbitrary shell commands, if user input is passed into libnotify.notify. Untrusted input passed in the call to libnotify.notify could result in execution of shell commands. Callers may be unaware of this. Example Special thanks to Neal Poole for submitting the pull request to fix this issue. Recommendation Update to version 1.0.4 or greater
Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.