Potential Command Injection in libnotify
CVE-2013-7381GHSA-6898-wx94-8jq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (libnotify 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm libnotify
- Affected
- <= 1.0.3
- Fixed in
- 1.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6898-wx94-8jq8 lists affected ranges: npm libnotify >=0 <1.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6898-wx94-8jq8 lists affected ranges: npm libnotify >=0 <=1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2013-7381: 2.69% estimated exploitation activity in the next 30 days; percentile 85.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions 1.0.3 and earlier of libnotify are affected by a shell command injection vulnerability. This may result in execution of arbitrary shell commands, if user input is passed into libnotify.notify. Untrusted input passed in the call to libnotify.notify could result in execution of shell commands. Callers may be unaware of this. Example Special thanks to Neal Poole for submitting the pull request to fix this issue. Recommendation Update to version 1.0.4 or greater
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6898-wx94-8jq8
- Revision 1 · created ·
Published from osv record GHSA-6898-wx94-8jq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-7381 Advisory: Potential Command Injection in libnotify IDs: CVE-2013-7381, GHSA-6898-wx94-8jq8 Record: https://patchnext.com/advisories/cve-2013-7381 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: libnotify 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm libnotify: affected <= 1.0.3; fixed in 1.0.4 ## Suggested inspection (read-only) - `npm ls libnotify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on libnotify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6898-wx94-8jq8 (OSV record GHSA-6898-wx94-8jq8 lists affected ranges: npm libnotify >=0 <1.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-6898-wx94-8jq8 (GitHub-reviewed advisory GHSA-6898-wx94-8jq8 lists affected ranges: npm libnotify >=0 <=1.0.3) Commands are suggestions: review each one before running it.
Loading voting…