Skip to content

← Public intelligence

npm package

less-openui5

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3npmAmendedPublished

    Processing untrusted theming resources might execute arbitrary code (ACE)

    CVE-2021-21316 · GHSA-3crj-w4f5-gwh4

    Affected
    • npm less-openui5 < 0.10.0
    Fixed in
    0.10.0· Vendor fix available
    Issue
    Impact When processing theming resources (i.e. .less files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process. While this is a feature of the Less.js library, it is an unexpected behavior in the context of OpenUI5 and SAPUI5 development. Especially in the context of UI5 Tooling, which relies on less-openui5, this poses a security threat: An attacker might create a library or theme-library containing a custom control or theme, hiding malicious JavaScript code in one of the .less files. This is an example of inline JavaScript in a Less file: Starting with Less.js version 3.0.0, the Inline JavaScript feature is disabled by default. less-openui5 however currently uses a fork of Less.js v1.6.3. Note that disabling the Inline JavaScript feature in Less.js versions 1.x, still evaluates code has additional double codes around it: Patches We decided to remove the inline JavaScript…

    Recommended action: Upgrade to 0.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →