Skip to content

← Actionable
Medium, CVSS 6.3amended

Processing untrusted theming resources might execute arbitrary code (ACE)

CVE-2021-21316GHSA-3crj-w4f5-gwh4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (less-openui5 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
EPSS
  • CVE-2021-21316: 0.99% estimated exploitation activity in the next 30 days; percentile 62.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When processing theming resources (i.e. .less files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process. While this is a feature of the Less.js library, it is an unexpected behavior in the context of OpenUI5 and SAPUI5 development. Especially in the context of UI5 Tooling, which relies on less-openui5, this poses a security threat: An attacker might create a library or theme-library containing a custom control or theme, hiding malicious JavaScript code in one of the .less files. This is an example of inline JavaScript in a Less file: Starting with Less.js version 3.0.0, the Inline JavaScript feature is disabled by default. less-openui5 however currently uses a fork of Less.js v1.6.3. Note that disabling the Inline JavaScript feature in Less.js versions 1.x, still evaluates code has additional double codes around it: Patches We decided to remove the inline JavaScript…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3crj-w4f5-gwh4

  2. Revision 1 · created ·

    Published from osv record GHSA-3crj-w4f5-gwh4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21316

Advisory: Processing untrusted theming resources might execute arbitrary code (ACE)
IDs: CVE-2021-21316, GHSA-3crj-w4f5-gwh4
Record: https://patchnext.com/advisories/cve-2021-21316 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: less-openui5 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm less-openui5: affected < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `npm ls less-openui5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on less-openui5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3crj-w4f5-gwh4 (OSV record GHSA-3crj-w4f5-gwh4 lists affected ranges: npm less-openui5 >=0 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3crj-w4f5-gwh4 (GitHub-reviewed advisory GHSA-3crj-w4f5-gwh4 lists affected ranges: npm less-openui5 >=0 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…