High, CVSS 7.5npmAmendedPublished
Unintended Require in larvitbase-api
CVE-2019-5479 · GHSA-xf27-jqwv-gf3r
- Affected
- npm larvitbase-api < 0.5.5
- Fixed in
- 0.5.5· Vendor fix available
- Issue
- Versions of larvitbase-api prior to 0.5.4 are vulnerable to an Unintended Require. The package exposes an API endpoint and passes a GET parameter unsanitized to an require() call. This allows attackers to execute any .js file in the same folder as the server is running. Recommendation Upgrade to version 0.5.4 or later.
Recommended action: Upgrade to 0.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.