Unintended Require in larvitbase-api
CVE-2019-5479GHSA-xf27-jqwv-gf3r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (larvitbase-api 0.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm larvitbase-api
- Affected
- < 0.5.5
- Fixed in
- 0.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xf27-jqwv-gf3r lists affected ranges: npm larvitbase-api >=0 <0.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xf27-jqwv-gf3r lists affected ranges: npm larvitbase-api >=0 <0.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-5479: 1.29% estimated exploitation activity in the next 30 days; percentile 70.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of larvitbase-api prior to 0.5.4 are vulnerable to an Unintended Require. The package exposes an API endpoint and passes a GET parameter unsanitized to an require() call. This allows attackers to execute any .js file in the same folder as the server is running. Recommendation Upgrade to version 0.5.4 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xf27-jqwv-gf3r
- Revision 1 · created ·
Published from osv record GHSA-xf27-jqwv-gf3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-5479 Advisory: Unintended Require in larvitbase-api IDs: CVE-2019-5479, GHSA-xf27-jqwv-gf3r Record: https://patchnext.com/advisories/cve-2019-5479 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: larvitbase-api 0.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm larvitbase-api: affected < 0.5.5; fixed in 0.5.5 ## Suggested inspection (read-only) - `npm ls larvitbase-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on larvitbase-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xf27-jqwv-gf3r (OSV record GHSA-xf27-jqwv-gf3r lists affected ranges: npm larvitbase-api >=0 <0.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-xf27-jqwv-gf3r (GitHub-reviewed advisory GHSA-xf27-jqwv-gf3r lists affected ranges: npm larvitbase-api >=0 <0.5.5) Commands are suggestions: review each one before running it.
Loading voting…