Skip to content

← Public intelligence

npm package

import-in-the-middle

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1npmAmendedPublished

    import-in-the-middle has unsanitized user controlled input in module generation

    CVE-2023-38704 · GHSA-5r27-rw8r-7967

    Affected
    • npm import-in-the-middle <= 1.4.1
    Fixed in
    1.4.2· Vendor fix available
    Issue
    Impact The import-in-the-middle loader works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function. Patches This vulnerability has been patched in import-in-the-middle version 1.4.2 Workarounds Do not pass any user-supplied input to import(). Instead, verify it against a set of allowed values. If using import-in-the-middle and support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or the NODEOPTIONS environment variable): References If you have any questions or comments about this advisory, email us at security@datadoghq.com

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →