import-in-the-middle has unsanitized user controlled input in module generation
CVE-2023-38704GHSA-5r27-rw8r-7967
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (import-in-the-middle 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.4.1
- Fixed in
- 1.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5r27-rw8r-7967 lists affected ranges: npm import-in-the-middle >=0 <1.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r27-rw8r-7967 lists affected ranges: npm import-in-the-middle >=0 <=1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2023-38704: 1.00% estimated exploitation activity in the next 30 days; percentile 62.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The import-in-the-middle loader works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function. Patches This vulnerability has been patched in import-in-the-middle version 1.4.2 Workarounds Do not pass any user-supplied input to import(). Instead, verify it against a set of allowed values. If using import-in-the-middle and support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or the NODEOPTIONS environment variable): References If you have any questions or comments about this advisory, email us at security@datadoghq.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5r27-rw8r-7967
- Revision 1 · created ·
Published from osv record GHSA-5r27-rw8r-7967
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38704 Advisory: import-in-the-middle has unsanitized user controlled input in module generation IDs: CVE-2023-38704, GHSA-5r27-rw8r-7967 Record: https://patchnext.com/advisories/cve-2023-38704 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: import-in-the-middle 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm import-in-the-middle: affected <= 1.4.1; fixed in 1.4.2 ## Suggested inspection (read-only) - `npm ls import-in-the-middle --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on import-in-the-middle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5r27-rw8r-7967 (OSV record GHSA-5r27-rw8r-7967 lists affected ranges: npm import-in-the-middle >=0 <1.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5r27-rw8r-7967 (GitHub-reviewed advisory GHSA-5r27-rw8r-7967 lists affected ranges: npm import-in-the-middle >=0 <=1.4.1) Commands are suggestions: review each one before running it.
Loading voting…