Skip to content

← Public intelligence

npm package

hummus

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Unchecked Return Value to NULL Pointer Dereference in PDFDocumentHandler.cpp

    CVE-2022-39381 · GHSA-rcrx-fpjp-mfrw

    Affected
    • npm hummus < 1.0.111
    Fixed in
    1.0.111· Vendor fix available
    Issue
    Impact The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be appended to another. Patches It has been patched in 2.6.0 for muhammara and not at all for hummus Workarounds Do not process files from untrusted sources References PR: https://github.com/julianhille/MuhammaraJS/pull/194 Issue: https://github.com/julianhille/MuhammaraJS/issues/191 Issue in hummus: https://github.com/galkahana/HummusJS/issues/293 Outline differences to https://nvd.nist.gov/vuln/detail/CVE-2022-25892 The difference is one is in src/deps/PDFWriter/PDFParser.cpp and the other is PDFDocumentHandler.cpp both is a null pointer but for different cases These are totally diffent issues, one is in reading a pdf the other is in appendending a maliciously crafted one. The function calls are different the versions in which they are solved are diffent.

    Recommended action: Upgrade to 1.0.111 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    muhammara and hummus vulnerable to denial of service by NULL pointer dereference

    CVE-2022-25892 · GHSA-9cv5-4wqv-9w94

    Affected
    • npm hummus < 1.0.111
    Fixed in
    1.0.111· Vendor fix available
    Issue
    Impact The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. Patches It has been patched in 3.1.1 and has been backported to 2.6.1 Hummus has a patch in 1.0.111. Workarounds Do not process files from untrusted sources or update. References https://nvd.nist.gov/vuln/detail/CVE-2022-25892 https://github.com/galkahana/HummusJS/issues/463 https://github.com/julianhille/MuhammaraJS/issues/214 https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002 https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51 https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138 https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320

    Recommended action: Upgrade to 1.0.111 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    muhammara and hummus vulnerable to null pointer dereference on bad response object

    CVE-2022-25885 · GHSA-frp9-2v6r-gj97

    Affected
    • npm hummus >= 1.0.0, <= 1.0.110
    Fixed in
    1.0.111· Vendor fix available
    Issue
    The package muhammara before 2.6.0 and the package hummus before 1.0.111 are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.

    Recommended action: Upgrade to 1.0.111 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →